Slimjet 31 and 32.0.1.0 - 32bit Does not Launch on Linux

Slimjet bug reports
Post Reply
Average Joe
Posts: 4
Joined: Wed Jul 14, 2021 4:27 am

Slimjet 31 and 32.0.1.0 - 32bit Does not Launch on Linux

Post by Average Joe »

Hi everyone.

I've been using and recommending Slimjet to everyone since a long time. (Meanwhile I know 32bit will be dropped soon.)

I'm an MX Linux user. Slimjet is installed (always with no issues) via "MX Package Installer" tool. (Currently MX 19.4 , based on Debian 10 - Buster )

I know, you'll say to write in MX forum. But the packages are coming directly from Flashpeak-Slimjet sources and also the installation finished successfully (re-installed 2 times).

Last time it was ok with 30.0.x.x

(Currently I'm writing on Windows 30.0.4 )

I guess there may be just a tiny thing preventing Slimjet to start (I also tried from Terminal). This is also a kind of feedback ...

Code: Select all

$ apt-cache policy slimj*
slimjet:
  Installed: 31.0.1.0
  Candidate: 31.0.1.0
  Version table:
 *** 31.0.1.0 100
        100 /var/lib/dpkg/status

Code: Select all

$ apt list *slimj*
Listing... Done
slimjet/now 31.0.1.0 i386 [installed,local]
Thank you all in advance.
Last edited by Average Joe on Sat Sep 25, 2021 12:28 pm, edited 2 times in total.

Average Joe
Posts: 4
Joined: Wed Jul 14, 2021 4:27 am

Re: Slimjet 31.0.1.0 - 32bit Does not Start on Linux

Post by Average Joe »

P.S. I already tried these:
  • Renamed slimjet folder in ~/.config
  • Created a new user and tried to start it there
  • Left only en-GB.pak and en-US.pak in /opt/slimjet/locales/
... nothing changed.

... If I try to manually run the sh in a terminal:

Code: Select all

$ sh /usr/bin/flashpeak-slimjet
/usr/bin/xdg-settings
/usr/bin/flashpeak-slimjet: 147: /usr/bin/flashpeak-slimjet: [[: not found
/usr/bin/flashpeak-slimjet: 162: /usr/bin/flashpeak-slimjet: Syntax error: "(" unexpected (expecting "fi")

fisher0815
Posts: 1
Joined: Fri Jul 16, 2021 10:04 am

Re: Slimjet 31.0.1.0 - 32bit Does not Start on Linux

Post by fisher0815 »

I'm using Debian Buster 32-Bit und Slimjet 32-Bit works till version 30.0.5.0.
Version 31.0.1.0 and 31.0.0.0 doesn't work any more. It starts, but I've got an error page and I can't call any web address.

uname -a
Linux acer 4.19.0-17-686-pae #1 SMP Debian 4.19.194-2 (2021-06-21) i686 GNU/Linux

The startup output of the not working version 31.0.1.0:

Code: Select all

m@acer:~$ flashpeak-slimjet 
execv failed: No such file or directory
[1:1:0716/175806.457869:ERROR:nacl_fork_delegate_linux.cc(329)] Bad NaCl helper startup ack (0 bytes)
[6057:6057:0716/175806.701339:ERROR:gl_implementation.cc(285)] Failed to load /opt/slimjet/libGLESv2.so: /opt/slimjet/libGLESv2.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
[6057:6057:0716/175806.732783:ERROR:viz_main_impl.cc(150)] Exiting GPU process due to errors during initialization
[6086:6086:0716/175806.893013:ERROR:gpu_init.cc(426)] Passthrough is not supported, GL is egl
[5883:6015:0716/175807.033034:ERROR:nacl_browser.cc(290)] Failed to open NaCl IRT file "/opt/slimjet/nacl_irt_x86_32.nexe": -4
[6108:6108:0716/175807.130096:ERROR:gpu_init.cc(426)] Passthrough is not supported, GL is egl
[6135:6135:0716/175807.294678:ERROR:gpu_init.cc(426)] Passthrough is not supported, GL is egl
[6153:6153:0716/175807.390559:ERROR:gpu_init.cc(426)] Passthrough is not supported, GL is disabled
[6178:6178:0716/175807.544712:ERROR:gpu_init.cc(426)] Passthrough is not supported, GL is disabled
[6178:6178:0716/175807.548024:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
The startup output of the working version 30.0.5.0.:

Code: Select all

m@acer:~$ flashpeak-slimjet 
execv failed: No such file or directory
[1:1:0716/180223.909463:ERROR:nacl_fork_delegate_linux.cc(329)] Bad NaCl helper startup ack (0 bytes)
[28274:28274:0716/180224.209548:ERROR:gl_implementation.cc(282)] Failed to load /opt/slimjet/libGLESv2.so: /opt/slimjet/libGLESv2.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
[28274:28274:0716/180224.272254:ERROR:viz_main_impl.cc(150)] Exiting GPU process due to errors during initialization
[28105:28264:0716/180224.402745:ERROR:login_database.cc(641)] Password store database is too new, kCurrentVersionNumber=28, GetCompatibleVersionNumber=29
[28105:28264:0716/180224.402974:ERROR:password_store_default.cc(39)] Could not create/open login database.
[28105:28264:0716/180224.407814:ERROR:login_database.cc(641)] Password store database is too new, kCurrentVersionNumber=28, GetCompatibleVersionNumber=29
[28105:28264:0716/180224.415721:ERROR:password_store_default.cc(39)] Could not create/open login database.
[28105:28220:0716/180224.457392:ERROR:nacl_browser.cc(290)] Failed to open NaCl IRT file "/opt/slimjet/nacl_irt_x86_32.nexe": -4

Average Joe
Posts: 4
Joined: Wed Jul 14, 2021 4:27 am

Re: Slimjet 31.0.1.0 - 32bit Does not Start on Linux

Post by Average Joe »

Today installed 32.0.0

Still the same. Not launching :(

Average Joe
Posts: 4
Joined: Wed Jul 14, 2021 4:27 am

Re: Slimjet 31 and 32.0.0 - 32bit Does not Launch on Linux

Post by Average Joe »

Sorry but 32.0.1.0 is no different, though it says in "What's new" : "Fix starting issue with linux version." .

Everytime I remove them and turn back to 30.0.5

Just looking at the conky: When you click to launch, the Cpu and Ram moves up for a moment as if it'll start, but that's all, nothing more ..

markm-lt20
Posts: 1
Joined: Tue Oct 26, 2021 5:34 am

Re: Slimjet 31 and 32.0.1.0 - 32bit Does not Launch on Linux

Post by markm-lt20 »

I have just installed the latest Slimjet v32 on a fresh install of Linux Mint Xfce 32 bit.
Initially, the program crashed on launch. After that, it would launch and open but anything entered in the address box resulted in an error message that the program could not connect to the internet. I couldn't even get to settings without the same error message.

Next, I completely purged v32 and installed the last v31 on same computer with same results.

I then completely purged v31 and installed the last v30 of Slimjet. v30 works without any issue as previously reported.

Is anything being done to make new versions of Slimjet operational on 32 bit systems or will v30 remain the last working version?

Post Reply