Launched Slimjet on bash shell, error yet go on running

Slimjet bug reports
Post Reply
budikusasi
Posts: 10
Joined: Sat Feb 18, 2017 1:40 am

Launched Slimjet on bash shell, error yet go on running

Post by budikusasi »

I tried to launch latest Slimjet on Manjaro Linux shell,

Code: Select all

$ flashpeak-slimjet
[11014:11014:0716/070220.724881:ERROR:gl_implementation.cc(286)] Failed to load /opt/slimjet/libGLESv2.so: /opt/slimjet/libGLESv2.so: cannot open shared object file: No such file or directory
[11014:11014:0716/070220.732306:ERROR:viz_main_impl.cc(152)] Exiting GPU process due to errors during initialization
MESA-LOADER: failed to retrieve device information
MESA-LOADER: failed to open radeon (search paths /usr/lib/dri)
failed to load driver: radeon
MESA-LOADER: failed to open kms_swrast (search paths /usr/lib/dri)
failed to load driver: kms_swrast
MESA-LOADER: failed to open swrast (search paths /usr/lib/dri)
failed to load swrast driver
yet it didn't disrupt instead it worked running
How to solve the error of this imperfection ? Thanks before.

scott092707
Posts: 29
Joined: Wed Jul 26, 2017 5:24 pm

Re: Launched Slimjet on bash shell, error yet go on running

Post by scott092707 »

With the installation of the newer SJ version 27.0.5.0, there are a number of graphics-card-related errors, as was noted above.
Mine are slightly different, as the kernel driver is amdgpu, not radeon, and my search paths are more complicated, for some reason.
I also get the error that appears last in the code block, and it does not always occur at the same point in the output (but always after the other errors).
Here, it occurs twice, but in other logs it has occurred 4, 6 or 8 times - seemingly always in pairs...(?)
(I don't know if the OP didn't get these errors, or didn't notice them.)

These errors appear whether I am launching SJ from LXQt or Wayland/Sway.

Code: Select all

[148317:148317:0816/155405.644108:ERROR:gl_implementation.cc(286)] Failed to load /opt/slimjet/libGLESv2.so: /opt/slimjet/libGLESv2.so: cannot open shared object file: No such file or directory
[148317:148317:0816/155405.657052:ERROR:viz_main_impl.cc(152)] Exiting GPU process due to errors during initialization
MESA-LOADER: failed to retrieve device information
MESA-LOADER: failed to open amdgpu (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
failed to load driver: amdgpu
MESA-LOADER: failed to open kms_swrast (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
failed to load driver: kms_swrast
MESA-LOADER: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
failed to load swrast driver
...
[148331:148331:0816/155420.699665:ERROR:gles2_cmd_decoder.cc(3601)] ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader
[148331:148331:0816/155420.716753:ERROR:gles2_cmd_decoder.cc(3601)] ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader
Here is my current system:

Code: Select all

scott@ASUS-Prime-B350M-A-CSM:~$  sudo inxi -Fmr 
[sudo] password for scott: 
System:    Host: ASUS-Prime-B350M-A-CSM Kernel: 5.7.0-2-amd64 x86_64 bits: 64 Desktop: sway 1.5 
           Distro: Debian GNU/Linux bullseye/sid 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B350M-A v: Rev X.0x serial: 180323995200247 UEFI: American Megatrends 
           v: 4207 date: 12/07/2018 
Memory:    RAM: total: 15.15 GiB used: 3.01 GiB (19.8%) 
           Array-1: capacity: 256 GiB slots: 4 EC: None 
           Device-1: DIMM_A1 size: No Module Installed 
           Device-2: DIMM_A2 size: 16 GiB speed: 2400 MT/s 
           Device-3: DIMM_B1 size: No Module Installed 
           Device-4: DIMM_B2 size: No Module Installed 
CPU:       Topology: Quad Core model: AMD A12-9800E RADEON R7 12 COMPUTE CORES 4C+8G bits: 64 type: MCP L2 cache: 1024 KiB 
           Speed: 1299 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 827 2: 797 3: 1860 4: 1856 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] driver: amdgpu v: kernel 
           Device-2: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] driver: amdgpu v: kernel 
           Display: server: X.org 1.20.8 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa 
           Message: Advanced graphics data unavailable for root. 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 15h Audio driver: snd_hda_intel 
           Device-3: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] driver: snd_hda_intel 
           Device-4: Cambridge Silicon Radio CSR Audio Dongle type: USB driver: snd-usb-audio 
           Device-5: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k5.7.0-2-amd64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: 4c:ed:fb:94:3b:f4 
           Device-2: Edimax type: USB driver: rtl88XXau 
           IF: wlx74da38f6702e state: up mac: 74:da:38:f6:70:2e 
Drives:    Local Storage: total: 945.96 GiB used: 438.42 GiB (46.3%) 
           ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
           ID-2: /dev/sdb type: USB vendor: PNY model: USB 2.0 FD size: 14.45 GiB 
Partition: ID-1: / size: 19.56 GiB used: 14.82 GiB (75.8%) fs: ext4 dev: /dev/sda6 
Swap:      ID-1: swap-1 type: partition size: 16.00 GiB used: 0 KiB (0.0%) dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 32.6 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 32 C device: amdgpu temp: 37 C fan: 956 
Repos:     Active apt repos in: /etc/apt/sources.list 
           1: deb https://deb.debian.org/debian/ testing main contrib non-free
           2: deb-src https://deb.debian.org/debian/ testing main contrib non-free
           3: deb https://deb.debian.org/debian/ testing-updates main contrib non-free
           4: deb https://deb.debian.org/debian-debug/ testing-debug main contrib non-free
           5: deb https://security.debian.org/debian-security/ testing/updates non-free contrib main
           6: deb-src https://security.debian.org/debian-security/ testing/updates main contrib non-free
           7: deb http://ppa.launchpad.net/mkusb/ppa/ubuntu/ focal main
           Active apt repos in: /etc/apt/sources.list.d/opera-stable.list 
           1: deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
Info:      Processes: 254 Uptime: 2h 34m Shell: Bash inxi: 3.1.05 

Post Reply