DRM-contents still not work in Slimjet (23.0.1.0 beta)

Slimjet bug reports
Post Reply
mardimus
Posts: 10
Joined: Sun Feb 18, 2018 8:34 am

DRM-contents still not work in Slimjet (23.0.1.0 beta)

Post by mardimus » Wed May 22, 2019 11:23 am

I had great hopes that this problem had been finally solved in this beta, but unfortunately it wasn't. It would be interesting to know why it isn't working in Slimjet, but it works fine in Vivaldi which is also chromium-based browser? Last year Vivaldi developer Ruarí Ødegaard told that from now on Widevine support is also for Linux users: "Vivaldi now fetches Widevine during the install mechanism, meaning it should work out of the box for all Linux users". What are they doing different? Why it isn't possible also in Slimjet?

I like Slimjet a lot. It's a speedy browser with low memory usage. Perfect especially for older computers. But if I can't watch paid sport channels because of DRM-content not working, there is now point to use this browser any more. I'll stick with Vivaldi and Firefox from now on. But this is not farewell for ever. I'll be back if things get better in near future...;)

System: HP-250-G6-Notebook-PC
Desktop: KDE Plasma 5.12.7
Kernel: 4.18.0-20-generic x86_64
Distro: Ubuntu 18.04.2 LTS
Graphics: Intel HD Graphics 620

pigeonskiller
Posts: 9
Joined: Wed Jan 02, 2019 10:57 am

Re: DRM-contents still not work in Slimjet (23.0.1.0 beta)

Post by pigeonskiller » Fri May 24, 2019 6:56 am

Same problem for me in Linux...
I'm testing Chromium 74 for curiosity and it is working flowlessly with DRM-contents!
I already reported this bug in previous versions in the forum but seems developers don't want or aren't able to fix bugs...

Herbert Kern
Posts: 6
Joined: Sat Jun 18, 2016 4:49 am

Re: DRM-contents still not work in Slimjet (23.0.1.0 beta)

Post by Herbert Kern » Sat Jul 06, 2019 11:08 am

Update: On version 23.0.9.0 of slimjet, amazon-prime-videos are played.
Problem is solved.
Thanks to the developers. :D

I am on LinuxMint19.1. Xfce

The last version of slimjet, where Amazon-Prime-Videos worked without any problems, was version 21.0.8.0
From then on, no newer version works for Amazon-Prime-Videos.
------------------------------------------------------
Another solution: Sometimes I use google-chrome browser. There amazon-prime-videos never ever refuse to play. They simply work.

Post Reply