Version 19: Blank buttons in extensions developer mode

Slimjet bug reports
Post Reply
temp_account
Posts: 51
Joined: Thu Mar 09, 2017 7:19 pm

Version 19: Blank buttons in extensions developer mode

Post by temp_account » Sun May 27, 2018 1:44 am

With the native standard theme the three buttons have a white font color on a white background and these buttons are:
"load unpacked"
"pack extensions"
"update"

I can't upload a screenshot. There is no more upload button. :roll:
Windows 7 x64, latest Slimjet x64, "strict site isolation" flag is enabled

CrockPot
Posts: 39
Joined: Sat Oct 28, 2017 7:26 am

Re: Version 19: Blank buttons in extensions developer mode

Post by CrockPot » Wed May 30, 2018 2:39 am

Confirming the same bug,attaching screenshot as well
Version 19.0.1.0 (based on Chromium 66.0.3359.117) (Official Build) (64-bit)
Windows 10 (x64) Enterprise LTSB 1607
https://drive.google.com/file/d/1_TLKXU ... sp=sharing

Extensions start using WAY TOO MUCH memory,prior update was like 2,030K each,after 19,516 (this bug needs fixing ASAP)
https://drive.google.com/file/d/1ICO0JT ... sp=sharing

This is important,hoping that dev would see it and fix it.Since updating to 19.0.1.0 noticed bunch of the same error start showing up in the slimjet://gpu. Didn't have any errors prior. Would really like if this is been looked at.Thank you.

5980:4168:0530/032336.131:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032351.128:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032424.545:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032430.505:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032434.644:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
5980:4168:0530/032654.808:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032914.405:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032917.224:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032951.180:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032959.472:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033017.180:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033209.732:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033242.464:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033302.078:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033400.508:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033408.707:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033548.394:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033624.017:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED

flashpeak
Site Admin
Posts: 361
Joined: Mon Apr 21, 2014 3:57 pm

Re: Version 19: Blank buttons in extensions developer mode

Post by flashpeak » Thu May 31, 2018 8:21 pm

temp_account wrote:
Sun May 27, 2018 1:44 am
With the native standard theme the three buttons have a white font color on a white background and these buttons are:
"load unpacked"
"pack extensions"
"update"

I can't upload a screenshot. There is no more upload button. :roll:
Issue confirmed. We will fix it.
Stephen Cheng
FlashPeak Inc.

flashpeak
Site Admin
Posts: 361
Joined: Mon Apr 21, 2014 3:57 pm

Re: Version 19: Blank buttons in extensions developer mode

Post by flashpeak » Thu May 31, 2018 11:43 pm

I compared the memory usage of the same extensions for Slimjet 18 and 19. They did use similar amount of memory. Slimjet 19 uses slightly more. But I compared with the memory usage of the same extensions in Chrome 66 and it is about the same level. For example, the youtube auto hd extension uses about 20MB on my system in Slimjet 18 and 19 and Chrome 66. Even a blank tab in Slimjet takes about 15MB memory.

It is true that Chromium/Chrome uses more memory with every major revision. The guys at Google are not particularly frugal in terms of memory usage. Too many features are now packed into Chrome. We might consider strip away some of the less popular features from Chrome when we build Slimjet.
CrockPot wrote:
Wed May 30, 2018 2:39 am
Confirming the same bug,attaching screenshot as well
Version 19.0.1.0 (based on Chromium 66.0.3359.117) (Official Build) (64-bit)
Windows 10 (x64) Enterprise LTSB 1607
https://drive.google.com/file/d/1_TLKXU ... sp=sharing

Extensions start using WAY TOO MUCH memory,prior update was like 2,030K each,after 19,516 (this bug needs fixing ASAP)
https://drive.google.com/file/d/1ICO0JT ... sp=sharing

This is important,hoping that dev would see it and fix it.Since updating to 19.0.1.0 noticed bunch of the same error start showing up in the slimjet://gpu. Didn't have any errors prior. Would really like if this is been looked at.Thank you.

5980:4168:0530/032336.131:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032351.128:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032424.545:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032430.505:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032434.644:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
5980:4168:0530/032654.808:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032914.405:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032917.224:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032951.180:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/032959.472:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033017.180:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033209.732:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033242.464:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033302.078:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033400.508:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033408.707:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033548.394:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
[5980:4168:0530/033624.017:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED
Stephen Cheng
FlashPeak Inc.

CrockPot
Posts: 39
Joined: Sat Oct 28, 2017 7:26 am

Re: Version 19: Blank buttons in extensions developer mode

Post by CrockPot » Fri Jun 01, 2018 12:53 am

Well i guess it's out of your hands to do anything about it(i can swear that the extensions's memory usage in chromium 64 was much less but it is what it is),regarding stripping some of the not needed features sounds like a great idea.What about the error that i'm seeing in chrome://gpu ([2604:176:0601/013348.817:ERROR:gles2_cmd_decoder_passthrough_doers.cc(4140)] : NOT IMPLEMENTED),any ideas on this one,i know for sure i didn't have it before updating?

temp_account
Posts: 51
Joined: Thu Mar 09, 2017 7:19 pm

Re: Version 19: Blank buttons in extensions developer mode

Post by temp_account » Mon Jun 18, 2018 4:22 pm

temp_account wrote:
Sun May 27, 2018 1:44 am
With the native standard theme the three buttons have a white font color on a white background and these buttons are:
"load unpacked"
"pack extensions"
"update"
Solved with 19.0.4
Windows 7 x64, latest Slimjet x64, "strict site isolation" flag is enabled

Post Reply