Aw Snap error on Ubuntu since upgrading to v18

General discussion about Slimjet, or other issues related to web browser in general.
dkcvi9lemz
Posts: 4
Joined: Thu Feb 15, 2018 9:39 pm

Aw Snap error on Ubuntu since upgrading to v18

Post by dkcvi9lemz »

I am getting Aw snap error when logging into Gmail

It only happens when I overwrite the libffmpg.so with the one from 0.20.3-linux-x64.zip

If I restore the default libffmpg.so that comes with Slimjet then the Aw Snap errors do not appear.

Problem with this is that I need the codecs because certain YouTube videos will give error if I dont have the linux codecs

Ubuntu Gnome 16.04 LTS

Slimjet 18.0.1.0 64 bit

dkcvi9lemz
Posts: 4
Joined: Thu Feb 15, 2018 9:39 pm

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by dkcvi9lemz »

No response?

Better yet why dont you stop removing the codecs from Linux in the first place? Brave browser does not do this and neither do the others. Not even Google Chrome removes the codecs so what do you gain from crippling your own software in this manner?

I was about to make a donation also but Im glad I learned about this problem first.

And since not a finger will be lifted to resolve the issue basically it means the linux version of Slimjet is deprecated / abandonware as of version 18

I will stop recommending it to people on the privacy forums.

sleeper10
Posts: 366
Joined: Thu Jun 23, 2016 7:34 pm

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by sleeper10 »

Replace the libffmpeg.so in slimjet with the one in chromium. Worked for me:
https://www.slimjet.com/en/forum/viewto ... 2&start=10

flobou5783
Posts: 6
Joined: Fri Feb 23, 2018 3:35 pm

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by flobou5783 »

Same problem, updated Slimjet today to version 18 and some websites start loading then go to an "Aw, Snap" error:
- Gmail
- Google Calendar
- Soundcloud
- Bandcamp (only when trying to play music)
- YouTube (video won't play, showing grey/snowy background with a help message - not an actual "Aw, Snap" for youtube)

Other websites seem to work fine, including Google Drive, Google Docs/Sheets/etc.

I tried:
- reloading page
- cleaning cookies+cache from All-Time history
- replacing Slimjet's libffmpeg.so with Chromium's 64.0.3282.167
- replacing Slimjet's libffmpeg.so with Github's 0.28.2
- updating Ubuntu
- rebooting computer

The only workaround I found for now is to use another browser (e.g. Chromium, which doesn't have the above errors).

Any other ideas? This is really problematic, I can use Chromium temporarily but it's really slowing me down (I really love Slimjet, besides this major problem).

I'm using Ubuntu Mate 16.04 LTS.

User avatar
oftentired
Posts: 1348
Joined: Tue May 13, 2014 3:14 am

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by oftentired »

Try using the Google VPN
For those of you who wear aluminum foil hats, the voices lie, don't believe them!

Running 32 Bit SJ on Win 7 Pro

flobou5783
Posts: 6
Joined: Fri Feb 23, 2018 3:35 pm

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by flobou5783 »

oftentired wrote:Try using the Google VPN
Thanks but what do you mean exactly?
The only thing I can find about "Google VPN" is that it's for Android; however Slimjet does not exist on Android (yet?), and I'm using a Thinkpad laptop with Ubuntu Mate 16.04 LTS.
I already use a VPN, but the error was there whether or not I was connected to my VPN.

So please let me know if there's a special kind of VPN I can use to bypass my problem (and where/how to find it).

User avatar
oftentired
Posts: 1348
Joined: Tue May 13, 2014 3:14 am

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by oftentired »

Instead of saying VPN I should have said it this way.

I have configured my internet connection so that it uses the Google Public DNS.

IP4 uses 8.8.8.8 and secondary 8.8.4.4
IP6 uses 2001:4860:4860::8888 and secondary 2001:4860:4860::8844

see this website for info

Can't help you with the how to. I have no idea how it is done on Ubuntu.
For those of you who wear aluminum foil hats, the voices lie, don't believe them!

Running 32 Bit SJ on Win 7 Pro

flobou5783
Posts: 6
Joined: Fri Feb 23, 2018 3:35 pm

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by flobou5783 »

I just tried changing my DNS to Google's, but it changes nothing for this problem.

Thanks for the suggestion; any other idea?

sleeper10
Posts: 366
Joined: Thu Jun 23, 2016 7:34 pm

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by sleeper10 »

Not sure it will help, but you could try opendns:
https://signup.opendns.com/homefree/

floOo5783
Posts: 5
Joined: Wed Dec 07, 2016 11:16 am

Re: Aw Snap error on Ubuntu since upgrading to v18

Post by floOo5783 »

Just tried it, no luck either.
I'm not sure this would be related to DNS... to me, it seems like a library/plugin or javascript issue since it's triggered by audio/video playback or advanced features.
Here's another example of "Aw, Snap" error: on https://www.telus.com/en/qc/mobility/ac ... ccessories
(browsing the rest of the website is fine, but on this page with more advanced display features, the error is triggered).

Also, note that this error is specific to Slimjet. It does not happen with Chrome, Chromium or Firefox (and the Chromium version is the same as the one used by Slimjet).

Locked