[Resolved] Youtube doesn't have playback controls anymore

General discussion about Slimjet, or other issues related to web browser in general.
Anonymosity
Posts: 200
Joined: Sun Feb 24, 2019 6:39 pm

Re: Youtube doesn't have playback controls anymore

Post by Anonymosity »

klokv10@outlook.com wrote:
Sun Apr 19, 2020 12:19 pm
I found the problem.

Go into your settings and make sure this "Disable reading from HTML5 canvas" is greyed out
It works, but I merely had to make an exception for that for www.youtube.com rather than disabling it everywhere.
Why does YouTube still play videos if I fake a Firefox user-agent without changing any preferences?

Captain_Obvious
Posts: 6
Joined: Mon Jan 31, 2022 2:00 am

Re: [Resolved] Youtube doesn't have playback controls anymore

Post by Captain_Obvious »

It would appear that, due to this YouTube bug, that the feature to "Disable Reading From HTML Canvas" has been permanently removed as of SlimJet 33.0.0.0. Although, for people who really want this feature, it can still be enable via the program shortcut commands:

Code: Select all

-disable-reading-from-canvas
Simply copy and paste that code at the very end of the "Target" section of the shortcut properties. You will disable reading from the HTML canvas as a result.

Important Note: You may still have functionality problems from websites such as YouTube if you choose to add that command to your shortcut target. However, you'll get the privacy that you desire.

LangjanBK
Posts: 2
Joined: Thu Apr 02, 2020 10:39 pm
Location: South Africa
Contact:

Re: [Resolved] Youtube doesn't have playback controls anymore

Post by LangjanBK »

As a beginner I have no idea what you mean by "Simply copy and paste that code at the very end of the "Target" section of the shortcut properties. You will disable reading from the HTML canvas as a result."
Where do I find "Target" section of "shortcut properties"?

User avatar
oftentired
Posts: 1609
Joined: Tue May 13, 2014 3:14 am

Re: [Resolved] Youtube doesn't have playback controls anymore

Post by oftentired »

• On your desktop, if you have the Slimjet icon
• Right click the Slimjet Icon and select Properties
• Now working with the Properties window
• (if the Shortcut tab is not selected already click it to select it)
• The Target text entry window should already be highlighted and easy to identify
• If not you should be able to identify it from the content which will look something like this
"C:\Program Files (x86)\Slimjet\slimjet.exe"
• You will want to copy paste the --disable-reading-from-canvas command to the end of it with a space in between so it looks like this
"C:\Program Files (x86)\Slimjet\slimjet.exe" --disable-reading-from-canvas
Possibly, if you find you occasionally want to have the canvas not disabled, you will want to create a second shortcut that does not have it added
For those of you who wear aluminum foil hats, the voices lie, don't believe them!

Running 32 Bit SJ on Win 10

Post Reply